Howto re-enable Mac Mail plugins after updates

Update for 10.6.7: Please try MailPluginFix to enable GrowlMail again. This should be much easier.

Today I upgraded my MacBook to the new released Mac OS X 10.6.4. Everything worked fine except that the update contained a new version of the Apple Mail application which disabled my GrowlMail plugin (not for the first time!). As I really need this plugin and I didn't want to wait for an update I did a little web research and came up with the following solution:

  • Quit the Mail application
  • Get the UUID of the new installed Mail and and Messages.framework

To do this open the Terminal application and execute the following two commands:

$ cat /Applications/Mail.app/Contents/Info.plist | grep UUID -A 1
$ cat /System/Library/Frameworks/Message.framework/Resources/Info.plist | grep UUID -A 1

You will find the UUIDs between the two string elements. For Mail 4.3 I got:

B842F7D0-4D81-4DDF-A672-129CA5B32D57
E71BD599-351A-42C5-9B63-EA5C47F7CE8E

  • If the plugin already got moved to "~/Library/Mail/Bundles (Disabled)/" move it back to "~/Library/Mail/Bundles/"
  • Open "/Library/Mail/Bundles/GrowlMail.mailbundle/Contents/Info.plist" with the Property List Editor (If no editor opens on double click you probably have to install the Xcode tools from your Mac OS X DVD)
  • Insert the two UUIDs under SupportedPluginCompatibilityUUID and save the document
  • Start the Mail APP and be happy :-)

This should also work for other Mail plugins. But if the plugin is incompatible with the new Mail version you will probably have problems starting Mail. If this happens you will have to remove the plugin again and you will have to wait for a plugin update.

As always try this at your own risk and don't forget to make a backup before you start. Good Luck!